
Photoshop Plugins for Image Processing and Analysis

John C. Russ
 (DrJohnRuss@GMail.com)

These 39 plugins provide important added functionality for Adobe Photoshop CS4 and CS5 Extended (they will 
run with all recent Photoshop versions, but those two are preferred for image analysis as they include built-in 
measurement capabilities). Photoshop functions can provide a significant amount of image processing and 
measurement capability, but there are gaps in performance which these routines are designed to fill. See below 
for restrictions regarding their use. 

The plugins require running in 32 bit mode. They can be applied to gray scale or RGB color images, either 8 
bits or 16 bits per channel. They can also be applied to a selected single channel of a color image (including Lab 
color) as a gray scale image. The entire image area is processed, ignoring any regions that may be defined. 
However, if a region has been established, any changes to the image will only appear within the region.

Download and unzip either the Macintosh or Windows version and place the folder with its contents in 
Photoshop’s Filters folder:

On the Mac, the location is Applications | Adobe Photoshop CS5 (or CS4) | Plug-ins | Filters;
Under Windows, the location is Applications | Adobe Photoshop CS5 (or CS4) | Plug-ins | Filters.

When Photoshop is next launched it will read the contents of the folder and will create three new entries in the 
Filter menu, each of which has sub-menu entries arranged alphabetically:

_Binary Image _Combine Images _Measure Features _Process Image

Apply Automatic Threshold
Distance Map Black Features
Fill Holes in Features
Morphological Closing
Morphological Opening
Outline Black Features
Prune Skeleton Branches
Shade Small Features by Area
Skeletonize Black Features
Skeleton End Points
Watershed Feature Separation

Add Reference Image
Cross-Correlate Ref. Image
Keep Darker Pixel Values
Keep Lighter Pixel Values
Ratio to Reference Image
Store Reference Image
Subtract Reference Image
Use Ref. Image as Markers

Count Black Features
Feature Numbers
Feature Size and Shape
Generate Line Grids
Total Area Fraction
Total Perimeter

Center-Weighted Brightness
Conditional Gaussian Filter
Convert to Int-Hue-Sat
Homomorphic Range Comp.
Hybrid Median Filter
Kuwahara Filter
Level Background  Shading
Local Equalization
Local Variance
Principal Color Components
Rank Sharpening Filter
Sobel Gradient Filter
Sobel Orientation Filter
Top Hat Brightness Difference

	


A brief description of each function is given below. These plugins can be incorporated in Photoshop Actions. In 
addition to the use of these plugins in the workshops taught by the author, these methods are covered in books 
such as those listed below. These include information on the algorithms used and the rationale for their 
application, as well as programming code. Many other texts also describe these methods and their use, not 
always with the same names.

For information on other useful sets of plugins, see the section at the bottom of this file.
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_Binary Image
These functions are normally applied after an image has been thresholded to black and white, with the black 
pixels representing structures, objects or features of interest and the white representing background. This is the 
same convention as that used throughout Photoshop. Some other programs use the opposite convention of white 
features and black background. Any pixels with values darker than 128 are treated as features, and vice versa.

Apply Automatic Threshold: Applies a thresholding operation to the brightness values of a gray scale or RGB 
color image (for a color image, the average of the red, green and blue) and produces a black and white binary 
result. In many applications, this is faster and more reproducible than manual thresholding with Image-
>Adjustments->Threshold.

Distance Map Black Features: Each pixel within a feature is assigned a gray scale value that represents the 
distance to the nearest point in the background. The result is autoscaled for features in which values would 
exceed 255. This result is called the Euclidean Distance Map or EDM. It is useful for some measurements, 
either of feature dimensions (the maximum value represents the radius of the largest inscribed circle) or 
separation distances (by inverting contrast so that it is performed on the background), often by combining this 
image with the skeleton. Thresholding the distance map of features or background is an efficient and accurate 
way to perform erosion and dilation, and is used in the Morphological Closing and Morphological Opening 
plugins described below.

Fill Holes in Features: Holes contained within features are filled in. “Holes” that intersect the boundary of the 
image are not filled in, as there is no information from beyond the boundaries to indicate whether they are 
closed or not. Since features are treated as contiguous for pixels that touch at corners or sides (8-
connectedness), the background is treated as contiguous only for pixels that touch along sides (4-
connectedness). This allows, for instance, a feature outline to be filled.

Morphological Closing: Performs a dilation followed by an erosion, using the distance map to achieve isotropic 
results with an accurate distance value (equal for the dilation and erosion). The user must specify the distance 
(in pixels, but not limited to integer values). The Windows version allows direct entry in a dialog. The Mac 
version requires the presence of a plain text file named Distance.txt on the desktop containing the numeric value 
(see the note below about text files).

Morphological Opening: Performs an erosion followed by a dilation, using the distance map to achieve 
isotropic results with an accurate distance value (equal for the dilation and erosion). The user must specify the 
distance (in pixels, but not limited to integer values). The Windows version allows direct entry in a dialog. The 
Mac version requires the presence of a plain text file named Distance.txt on the desktop containing the numeric 
value (see the note below about text files).

Outline Black Features: The pixels along the boundaries of the feature are shown as black lines, with 
everything else white. This is useful for measurements, for determining where regions touch (by applying it to 
different images or channels and then combining them), and for outlining objects in images for display purposes 
(by combining the outlines with the original image).

Prune Skeleton Branches: When a skeleton is used to represent a network (e.g., cell walls, grain boundaries), 
the tesselation should have no branches that end. Pruning removes such branches. In some instances, depending 
on the geometry of the skeleton, it may be necessary to repeat the skeletonization and pruning once to achieve a 
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clean result. The difference between the skeleton and the pruned skeleton can be used to isolate just the terminal 
branches.

Shade Small Features by Area: Measures the area of each feature in the image and shows features smaller than 
250 pixels with shades of gray proportional to the size. This allows small features typically resulting from dirt 
or noise to be rejected by thresholding with Image -> Adjustments -> Threshold. A setting of 255 will keep all 
existing features. Reducing the threshold setting will progressively remove larger ones. Features that touch any 
boundary of the image are eliminated as they cannot be measured.

Skeletonize Black Features: The skeleton is a set of lines that represent the basic topology (which can be 
described by the number of end points, number of branches and number of nodes). The skeleton can also be 
used to select ridge lines in the distance map. The count of nodes and end points is reported; the node count may 
not be reliable because the skeleton of two lines crossing at a low angle may result in two nodes. Intersections 
of the skeleton with the image borders are not counted as ends.

Skeleton End Points: After skeletonizing, this function selects just the end points (points with a single 
neighbor). These may be used for counting, as markers, and for other purposes. 

Watershed Feature Separation: In many cases, touching or slightly overlapped convex features can be 
separated (white lines drawn between them) using this routine. This uses the distance map to locate the 
boundaries.

 _Combine Images
These routines provide ways to combine two images together, pixel by pixel. In all cases, the “reference image” 
is stored beforehand (it is placed into a special disk file) and is not modified by the operation. In Windows the 
file location is the root of C:\, which must be accessible. The images remains in the file until a new reference 
image is stored. The reference image and the current image must have the same dimensions; it is not required 
that they have the same mode (grayscale, RGB, 8 bit or 16 bit).

Add Reference Image: The two sets of values are added together, replacing the original. The result is 
automatically scaled so that the darkest value is exactly black and the brightest exactly white. If these limits 
correspond to only a few pixels, manual or automatic levels adjustment (Image -> Adjustments -> Levels) can 
be applied afterwards to expand the contrast. When applied to two binary images, the result can be thresholded 
to obtain the Boolean AND (threshold below 128) or OR (threshold above 128) combinations.

Cross-Correlate Ref. Image: This routine is primarily used for finding matching patterns. The reference image 
should contain a target (centered and cropped) to be located in the current image. The resulting image has 
brightness values that indicate the degree to which the patterns match at each location. This is usually easier to 
interpret with gray scale rather than color images. An easy way to create the target image is File -> New and 
select the existing image in the drop-down Preset menu. Paste the target, which will automatically be centered; 
Layers -> Merge Layers; Store Reference Image; select the image to be processed. Then use Cross-Correlate 
Ref. Image. The images must be square, with dimensions in pixels equal to an exact power of 2 (128, 256, 512, 
1024, ...)

Keep Darker Pixel Values: The two sets of values are compared, and whichever pixel value is darker is kept. 
This is particularly useful for inserting lines such as skeletons or outlines to an original image.
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Keep Lighter Pixel Values: The two sets of values are compared, and whichever pixel value is lighter is kept. 
This is particularly useful for eliminating background regions from the original image. It can also be used to 
combine a skeleton with a distance map, combine multiple outlines to locate common regions, etc.

Ratio to Reference Image: The ratio of the brightness of each pixel in the current image to the corresponding 
one in the reference image is calculated and replaces the original. The results are scaled to fill the brightness 
range of the image. This is particularly useful for leveling uneven background lighting when the objects of 
interest can be removed and a second image acquired. Depending on how the camera records brightness, either 
this function or Subtract Reference Image will be the preferred method.

Store Reference Image: The current image is written to a special disk file so that it can be used in the other 
routines in this group. The image is not modified by any of the operations in this group, and remains in the file 
until replaced by another image.

Subtract Reference Image: The difference between the brightness of each pixel in the current image and the 
corresponding one in the reference image is calculated and replaces the original. The results are scaled to fill the 
brightness range of the image. This is particularly useful for leveling uneven background lighting when the 
objects of interest can be removed and a second image taken. Depending on how the camera records brightness, 
either this function or Ratio to Reference Image will be the preferred method.

Use Ref. Image as Markers: Any black pixels (i.e. darker than 128) in the reference image become the seeds for 
dilation that is constrained by the black features in the current image. The result is to select features in the 
current image that are marked by pixels in the reference image. Because constrained dilation is slow for large or 
complexly shaped features, this function may take some time, and in any event is terminated after 1000 
dilations. It is very useful for selecting features based on touching lines (outlines, for instance), characteristic 
internal points (e.g., cell nuclei), or grids of points.

_Measure Features
These routines provide measurement capabilities that supplement the functionality of the Photoshop Analysis 
menu. They treat any pixels darker than 128 as part of features to be measured, and any brighter pixels as 
background. Pixels are considered to be part of the same feature if the touch along their sides or at their corners 
(this 8-connected rule is different that Photoshop’s 4-connected rule in which regions are contiguous only if the 
pixels share an edge).

Count Black Features: The number of contiguous groups of pixels is counted and reported. Pixels are 
considered touching if either their sides or corners are adjacent. Features that touch any boundary of the image 
are not included. If you want to count these, use Select -> All and Edit -> Stroke to draw a one-pixel wide white 
line around the image boundaries. To count features that touch only two contiguous edges, shift the image one 
pixel to the right and down (Select -> All, hold down the Control/Command key and press the arrow keys).

Feature Numbers: Applies brightness shading to the features to indicate their ID numbers as recorded by the 
Feature Size and Shape function. Placing the cursor over the feature shows the value in the Info palette. For 
image with more than 100 features, the numbers cycle from 1 to 100 again. Because the built-in Photoshop 
conversion to gray scale shades alters pixel values, the results should be examined as RGB values.

Feature Size and Shape: This routine measures the area and perimeter of each feature, and from them 
calculates a value for circularity (defined as in the Photoshop measurements as 4 π Area / Perimeter2). The 
resulting data are written to a file named Size+Shape.txt. This is a plain text file containing tab-delimited values, 
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which can be opened in most word processors, spreadsheet programs, and statistics packages. The Mac version 
writes the file to the desktop. The Windows version writes the file to the root of the C:\ drive (write permission 
is required). In addition to the data output, the features are color coded according to the circularity values 
(colors vary from red for the highest value to orange, yellow, green, blue and magenta for lower values). Note 
that the measurement values are not identical to those reported by the Photoshop Analysis->Record 
Measurements function, which measures things differently. The region boundaries lie around features rather 
than passing through the centers of the border pixels, and pixels are considered to be part of the same feature 
only if they share sides (4-connectedness) rather than also including corner-touching (8-connectedness).

Generate Line Grids: Grids of lines are used for many different types of measurements, typically by combining 
them with the thresholded binary image or an outline image using an AND, followed by measurement or 
counting. Four types of grids are provided: parallel vertical lines, squares, concentric circles, and cycloids. A 
user-supplied spacing value (in pixels) controls the distance between the lines, and for the cycloids the radius of 
the generating circle. The selection of the grid type and the spacing are each entered in a dialog for the Windows 
version, and read from a plain text file named Grids.txt on the desktop for the Mac version (see the note below 
about text files). The parallel lines can be rotated to any angle using the Photoshop Image -> Image Rotation -> 
Arbitrary function (use Bicubic interpolation and then apply skeletonization). Depending on the spacing value, 
the circle and cycloid grids will include a few doubled pixels due to limited arithmetic precision (apply 
skeletonization). The length of grid lines can be measured using the Filter -> _Measure Features -> Measure 
Total Perimeter function (this reports twice the actual length in pixels, since it measures along both sides of 
each line). The square line grid can be converted to a point grid using Filter -> Noise -> Median.

Total Area Fraction: The percentage of the image that consists of black pixels (i.e., darker than 128) is 
reported, along with the total image area in pixels.

Total Perimeter: The total length of the perimeter around all black features (i.e. darker than 128) is reported in 
pixels. The calculation uses the chain-code length of the boundary. The intersections of features with the image 
boundaries are not included, and they are not actual feature perimeter. For measuring lines, the line length is 
half of the perimeter (which runs along both sides). 

About text files on the Macintosh: The input files used to enter control parameters on the Macintosh must be 
plain text. Unfortunately, it is possible to have a file with the correct name (e.g., Grids.txt) that is not plain text 
but contains some formatting information. Sometimes the attempt to read parameters from an improperly 
formatted file can crash the plugin and/or Photoshop! Programs such as TextEdit do NOT create proper plain 
text files, even if Format->Make Plain Text is applied, but TextEdit CAN open, edit and save them. Example 
files Grids.txt and Distance.txt are provided with the plugins, and can be placed on the desktop, edited and 
saved using TextEdit.

 _Process Image
These functions supplement the image processing routines built into Photoshop (such as Gaussian Blur, Median 
Filter, Unsharp Mask, Maximum, Minimum [also called erosion and dilation], Curves or Levels adjustment, 
etc.). They provide additional levels of functionality and results, based on advanced, well established 
algorithms.

Center-Weighted Histogram: This modifies the pixel brightness values to change the brightness histogram to an 
approximately Gaussian, centered shape. It is useful as a supplement to the Photoshop Adjustments -> Equalize 
routine and particularly suitable for high contrast and high dynamic range images, to assist in on-screen viewing 
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or printing. Similar effects can be produced with the Image -> Adjustments -> Curves function but this does not 
require manual manipulation.

Conditional Gaussian Filter: In order to reduce random speckle noise without degrading steps and edges, the 
weight of the Gaussian smoothing is adjusted according to the difference between the pixel and its neighbors. 
This approach is also known as a Bilateral filter.

Convert to Int-Hue-Sat: The channel values in an RGB Color image are converted to Intensity, Hue and 
Saturation. The channel names are not changed in this process, so it is necessary to be careful in using the 
converted image. The IHS color channels are often useful for thresholding and other processing, as an 
alternative to Photoshop’s Lab space.

Homomorphic Range Compression: High contrast images generally cannot be printed or viewed on the screen 
to show details in both the bright and dark regions. Homomorphic compression uses frequency processing and 
log space to compress the overall contrast range while preserving local contrast so that the details are more 
visually apparent.

Hybrid Median Filter: The conventional median filter fills in fine lines and rounds corners. The hybrid median 
does not. Median routines are the preferred ways to reduce random speckle or dropout image noise. This routine 
uses a neighborhood that is a 5 pixel wide circle.

Kuwahara Filter: This is also called a maximum likelihood filter. It sharpens edge contrast so that the location 
of brightness steps is well defined, often useful before thresholding and measurement.

Level Background Shading: Uneven lighting makes subsequent processing and measurement difficult. This 
routine automatically locates bright or dark points throughout the image (which are assumed to represent the 
same background structure), fits a polynomial function to those values, and removes the resulting variation from 
the original image to level the overall brightness (the result is also autoscaled to fill the contrast range). The 
original set of these plugins (described in The Image Processing Cookbook, Second Edition) lists two plugins, 
one to level bright background and one for dark background. By examining the statistics of the image 
histogram, it is usually possible to automatically make that decision, so there is now a single plugin that handles 
both cases.

Local Equalization: Every pixel in the image is compared to the brightness of pixels in a 9 pixel wide circle 
around it. If the pixel is brighter than most of its neighbors, it is made brighter still (and vice versa). The result 
eliminates changes in average brightness from one portion of the image to another, while retaining and 
enhancing local contrast to show local detail.

Local Variance: The statistical variance of the brightness values of pixels in a 7 pixel wide circular 
neighborhood is calculated, and replaces the original pixel brightness value. In some cases this is a useful edge 
delineation tool, and in others it is a good detector of texture.

Principal Components: Principal Components Analysis (PCA) is applied to the RGB channels of the image to 
find the linear combinations that correspond best to the actual colors that are present. These are then computed, 
pixel by pixel, and assigned to the red, green and blue channels respectively. This approach is often useful for 
increasing the visibility of structures that have similar colors. In some cases it is useful to follow this operation 
with Image -> Adjustments -> Hue/Saturation and rotate the hue setting to obtain colors that are visually more 
distinct.
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Rank Sharpening Filter: Like the Filter -> Sharpen -> Unsharp Mask filter, this routine subtracts a “blurred” 
copy of the image (in which local detail has been eliminated) from the original, to enhance the visibility of the 
detail and edges. Instead of using a Gaussian blur, a ranking filter (with a 7 pixel wide circular neighborhood) is 
used so that the same enhancement is produced in both light and dark regions, and the presence of “halos” 
around edges that are characteristic of the unsharp mask are avoided.

Sobel Gradient Magnitude: The Sobel filter is widely used for edge or step delineation. It calculates the vector 
gradient of brightness at each point. This routine assigns the vector magnitude to each pixel. (This can be 
subsequently thresholded and skeletonized to delineate boundaries.)

Sobel Gradient Orientation: The gradient vector calculated by the Sobel filter also has a direction. This routine 
assigns that direction to the pixel brightness value. Combining these values with the outline from the Sobel 
gradient magnitude shows the orientation of boundaries. It can also be used to measure anisotropy in 
orientations of fibers, etc. The brightness scale 0....255 represents angles from 0...360 degrees.

Top Hat Brightness Difference: The difference between the maximum brightness values in a 3 pixel wide inner 
neighborhood and a 7 pixel wide annulus surrounding it is assigned to the pixel. This is used to find small bright 
spots (such as spikes in a Fourier transform power spectrum). To find dark spots, first invert the image. Setting a 
threshold on the resulting image selects the brightness difference.

======

Note: The plugins are based on, and use some of the programming code from, the textbook “Introduction to 
Image Processing and Analysis” (John Russ & Chris Russ, CRC Press, 2008). The use of this programming 
code carries the restriction that the resulting programs cannot be sold for profit or redistributed by others (i.e., it 
is OK to pass along the link but everyone should download their own copy). These plugins may be downloaded 
from the author’s website for personal use without fee by anyone who attends one of the author’s workshops or 
purchases one of his books, but with the request that users send an email with their name and contact 
information to the author at <DrJohnRuss@GMail.com>, so that they can be apprised of updates (I promise not 
to sell the names!). The following books are all available at Amazon.com.

J. Russ (2010) The Image Processing Handbook (6th edition), CRC Press (isbn 978-1439840450)
J. Russ (2011) The Image Processing Cookbook (2nd edition), Amazon CreateSpace (isbn 978-1456531010)
J. Russ, C. Russ (2008) Introduction to Image Processing and Analysis, CRC Press (isbn 978-0849370731)
J. Russ (2004) Image Analysis of Food Microstructure, CRC Press (isbn 978-0849322419 )

======

Some other plugins are available that can extend Photoshop’s capabilities to meet the needs of scientific, 
technical and forensic image processing and analysis. Some are free or very inexpensive. Demo versions of 
those that are not free are available that will run for a short period of time, or for a limited number of 
applications.

• 4N6site.com has a free Fourier transform and inverse transform combination that simplify pattern removal, 
and an inexpensive color deconvolution routine for removing unwanted colors to reveal a target (e.g., 
handwriting or fingerprint) of interest. Both are for Windows only.

• 3d4x.ch (http://www.3d4x.ch/?c=16,35) has free Fourier transform and inverse transform plugins, as well as 
plugins to convert between RGB and HSL color spaces. For Windows only.
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• ePaperPress.com has inexpensive PTLens software that can remove image distortions, and includes presets 
for many camera lenses. For both Windows and Macintosh.

• TopazLabs.com has inexpensive Topaz InFocus software for deconvolution of image blur. For both Windows 
and Macintosh.

• ReindeerGraphics.com sells Fovea Pro, a comprehensive but somewhat expensive set of tools that 
implement specific algorithms appropriate for scientific image processing and measurement, and can log 
data to facilitate automation. For Windows or Macintosh. From Reindeer Graphics, Inc., P.O. Box 2281, 
Asheville, NC 28802, 919-342-0209. Note: this site also offers a free download of the Wide Histogram 
plugin.

• OceanSystems.com sells ClearID, an expensive workflow-oriented set of image processing tools marketed for 
forensic images. For Windows only. From Ocean Systems, Inc., 4016 Blackburn Ln., Burtonsville, MD 
20866, 301-476-8015

• Pluginsite.com lists a huge number of free plugins (for both Windows and Mac), some of which may be 
useful in particular situations. There are many sites with plugins, actions and scripts (most of them 
unsuitable for technical applications) that can be found with Google.
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